-
Notifications
You must be signed in to change notification settings - Fork 347
Installation
One of the most common issues is installation of MB-Lab, which we all admit is a pain because of how GitHub packages release ZIP files. Please read CAREFULLY!!
Because of how Github packages releases this WILL affect how you install MB-Lab if downloading from the release page ONLY! If you download a clone where Github renames it MB-Lab-master, you will not have issues.
GitHub packages ZIP files with the version numbers in the name. The folder INSIDE this ZIP file is what needs to be changed, rename it from MB-Lab 1.x.x to MB-Lab-1-x-x or MBLAB if you want to be simple, just get rid of the periods in the directory name and Blender will recognize it and add the addon to the list.
This is because if you install an addon with periods, Blender assumes it is a file extension of some kind and gets confused, which causes confusion in most of installation issues with MB-Lab.
In Blender, open the user preferences window, choosing File → User Preferences in Blender 2.79
OR
Choose Edit → Preferences in Blender 2.80

Press the "Install from File" button in the left bottom side of the window

Use the file selector window in order to find the zip file, select it and click the button "Install from File".

When the installation will be completed, a new category named "Characters" will appear in the Categories list. Select it and enable the lab using the check button. When the plugin is enabled, remember to press the button "Save User Settings", in order to load the lab automatically each time you start Blender.


Close the User Preferences window. Press "N" to make the Sidebar with the MB-Lab interface appear in Blender 2.80
NOTE! Due to the Auto-Updater code having some bugs, at this time it is recommended that you MANUALLY DELETE MB-Lab if you choose to disable or remove MB-Lab.
In Blender, open the user preferences window, choosing File → User Preferences
In the addons tab, look for Characters → MB-Lab
Click on "Remove" button

It is VERY important to not have multiple copies of ManuelBastioniLAB or MB-Lab, there will be conflicts! Remove the old version first, then install from file the new version.
You can manually install MB-Lab as well. You need to unzip MB-Lab to the following directories for your OS.
C:\Users\USERNAME\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\
(WIP)
/home/USERNAME/.config/blender/2.80/scripts/addons/